Sound Aussetzer, Priorität für USB erhöhen?

Musikwiedergabe über PC und Mac

Sound Aussetzer, Priorität für USB erhöhen?

Beitragvon ZZTop » 24.12.2016, 09:16

Hi, ich habe ein Problem.
An meinem Laptop mit Win 10, 8GB Speicher und Intel Core i5 habe ich alle paar minuten beim Musikhören Sound Aussetzer bei meiner USB DAC, egal ob mit T+A, Auralis oder Musical Fidelity.
Zum abspielen meiner FLACs nutze ich JRiver. Die Aussetzer treten unabhänig von der Sampling Rate auf. Bei 44,1 KHz auch nicht weniger als bei files mit 192 KHz.
Win 10 habe ich erst neu aufgesetzt, und kann im Gerätemanager keine Konflikte sehen.
Während den Aussetzern (ca. 0,5 Sec.) kann ich weder im Taskmanager noch in der Leistungsüberwachung (DPC Rate) etwas auffälliges erkennen.
Ich habe schon einiges probiert. Ein Programm das den PC für Audiowiedergabe optimiert (Fidelizer), Win Defender abschalten, Page-File Abschalten, anderes USB-Kabel. Hat alles überhaupt keinen Einfluss gezeigt.

Kann mir jemand sagen ob/wie ich die USB Prozesse/Dienste höher priorisieren kann?
Bin auch für weitere Ideen die helfen könnten dankbar.

greetz
US
Bild
ZZTop
Aktiver Hörer
 
Beiträge: 51
Registriert: 15.03.2012, 14:27

Beitragvon Melomane » 24.12.2016, 09:23

Moin,

welche Möglichkeiten es noch in den Untiefen der Registry gibt, weiß ich nicht. Und ich kenne Win 10 auch nicht. Wenn das in dem Punkt noch so läuft wie ältere Windows-Versionen, könntest du probieren, den Player mit einer höheren Priorität, z.B. realtime, laufen zu lassen.

Aber ich verspreche mir letztlich nicht viel davon, da du ja schon alle möglichen Optimizer eingesetzt hast. Jedenfalls: Versuch macht kluch.

Gruß

Jochen
Bild
Melomane
Aktiver Hörer
 
Beiträge: 1626
Registriert: 14.10.2011, 17:30

Beitragvon ZZTop » 24.12.2016, 09:38

Danke für die Antwort.
Hab ich aber schon probiert. Egal ob normal, high oder Realtime. Macht keinen Unterschied.
Aber noch etwas ist mir aufgefallen. Die Dacs mit denen es Probleme gibt, laufen alle im usb asynchronous mode.
Der keine V90 von Musical Fidelity macht keine Aussetzer.

Uwe
ZZTop
Aktiver Hörer
 
Beiträge: 51
Registriert: 15.03.2012, 14:27

Beitragvon SolidCore » 24.12.2016, 11:26

Hallo Uwe

Welche Art des Outputs wählst du im Abspielprogramm vor ? Jedes hat so seine (möglichen) Tücken.
Schau mal in den Optionen.
Es gibt WASAPI, das sich gerne mal auf die in Windows eingestellte Samplerate einlässt, statt die tatsächliche zu verwenden.
Direktstream - was bei mir am wenigsten Probleme verursacht
ASIO - nochmal unterschieden in "ASIO4all" oder dem echtem, der hardware beigelegten Asio-Schnittstelle. Dort kannst du die Latenz verändern, manchmal erzeugt eine zu klein eingestellte Zeit Aussetzer. In einigen Player wie Foobar kann der Buffer ebenfalls erhöht werden, oder das Musikstück erst in den RAM geladen werden, und von dort abgespielt.

Ansonsten fallen mir noch die typischen Ideen ein, wie z.B den Treiber vom Motherboard aktualisieren, oder manchmal hilft auch die Treiberversion vor der aktuellen. Auch installierte USB 3.0 Treiber könnten stören, bzw durch andere ersetzt werden.

Vielleicht hast du das ein oder andere noch nicht versucht.

Gruss
Stephan
Bild
SolidCore
Aktiver Hersteller
 
Beiträge: 288
Registriert: 12.12.2014, 10:38

Beitragvon pschelbert » 24.12.2016, 11:45

Hallo

all diesen Ärger hatt ich auch, zwar mur mit Win7 und Win8, habe nur auf ienem Pad Win10.

Tipp: nur ASIO verwenden, das richtige ASIO, kein Asio4all.
Problem kann sein dass Dein DAC das nicht kann. Wenn er das nich tkann dann ist er nicht professionell und ich würde den ausrangieren.

Seit ich ASIO verwende läuft bei mir Realtime richtig. Gleichezitig Wiedergabe mit allen Kanälen und Aufnahme mit alen Kanälen und das gleichzeitig! Analog sind 12ADC und 12DAC.
Weiterer Vorteil von ASIO: das ganze Windows Sound System ist ausgeschaltet und kann daher kein Problem Fehler Soundänderungne erzeugen.

Kette ist:
Win7Pro-JRiverMC22-acourateconvolver-RME UFX-Poweramp
ich verwende auch USB asynchron

JRiver eingestellt ist=acourateasio
acourateconvolver eingestellt ist=ASIO Fireface USB

Peter
Bild
pschelbert
inaktiv
 
Beiträge: 1148
Registriert: 25.08.2015, 12:44

Beitragvon ZZTop » 24.12.2016, 12:21

Hallo Stefan
in JRiver gehe ich über WASAPI raus, das ich über den ASIO-Treiber vom Musical Fidelity (wird als Ausgabeoption angezeigt) kein Signal bekomme.
Mit meinem Fireface UCX funktioniert ASIO und ich habe sehr wenig Aussetzer. Eigentlich nur manchmal wenn sich die Samplerate ändert.
Ich hab auch schon versucht per USB aufs Fireface und dann per SPDIF auf den Wandler. Das funktioniert recht zuverlässig, klingt aber deutlich schlechter/härter.

Ich hab ja ein USB-Kabel von dir und das auch schon im Verdacht gehabt. Deswegen habe ich es mal durch die standard-USB 2.0 Strippe ausgetauscht. Die Aussetzer sind geblieben. Nur klingt es deutlich! schlechter als dein Solidcore USB Kabel. Hatte den Unterschied nich so groß in Erinnerung.

Treiber hab ich sämtliche aktualisiert/neu installiert. Hat auch nix gebracht. Zum Haare raufen!!!

greetz
Uwe
Bild
ZZTop
Aktiver Hörer
 
Beiträge: 51
Registriert: 15.03.2012, 14:27

Beitragvon uli.brueggemann » 24.12.2016, 12:29

Systemsteuerung - System - Erweiterte Systemeinstellungen - Leistungsoptionen - Hintergrunddienste wählen, evtl. auch visuelle Effekte auf optimale Leistung einstellen (graphische Darstellung wird einfacher, spielt aber auch nicht wirklich die Rolle)

Bei Asio-Treiber die Puffer erhöen.
Bei Windows Sound die Optiionen "Anwendungen haben alleinige Kontrolle" und "Anwendungen im exklusiven Modus haben Priorität" vorgeben.

Im Gerätemanager den Soundkartentreiber wählen. Dann Ansicht Geräte nach Verbindung wählen. Prüfen ob die Soundkarte den USB-Hub für sich allein hat oder noch mit anderen Geräten teilt. Einen USB-Steckplatz suchen, bei dem die Soundkarte den Hub für sich allein hat.

Grüsse
Uli
Bild
uli.brueggemann
Aktiver Hersteller
 
Beiträge: 3189
Registriert: 23.03.2009, 15:58
Wohnort: 33442

Beitragvon Piano Pianissimo » 24.12.2016, 12:36

Halo erstmal und ein frohes Fest vorab.

Das scheint wohl kein so ungewöhnliches Problem zu sein.

Habe WIN 10 mit allen Updates.
Rippe mit dBPoweramp
Streame mit Spotify
speichere ab mit Audials 2017
und übertrade drahtlos vom Computer zum Verstärker mit Syncronice. SKAA Transmitter

Mal mehr mal weniger kürzere oder längere Aussetzer.

Mein Dealer: von Computer haben wir keine Ahnung. Aber verkaufen kann er der .......

Der Hersteller hat mir ein TOP aktuelles Gerät getauscht. Brauchte auch nix.

Windows meint: Disable all enhancements - bringt aber auch nichts

pp
Bild
Piano Pianissimo
Aktiver Hörer
 
Beiträge: 84
Registriert: 23.05.2016, 15:15

Beitragvon ZZTop » 24.12.2016, 12:51

Super die Hilfe hier von allen Seiten :cheers: :cheers: :cheers:

Im Gerätemanager den Soundkartentreiber wählen. Dann Ansicht Geräte nach Verbindung wählen. Prüfen ob die Soundkarte den USB-Hub für sich allein hat oder noch mit anderen Geräten teilt. Einen USB-Steckplatz suchen, bei dem die Soundkarte den Hub für sich allein hat.


das kannte ich noch nicht. Den Rest hab ich schon probiert, Puffer alle auf maximale Größe, auch mal kleiner als normal probiert....

Ich hab jetzt in einem reinen PC-Forum erfahren, dass es evtl. ein Fehler war Win 10 "nur" aufzufrischen.
Ich mache jetzt eine komplette Neuinstallation!
Ich hoffe nur ich werde fertig bevor die Verwandschaft kommt. sonst gibts nur Radio.

@Uli
was brauche ich dann um Acourate und Convolver neu zu installieren?

greetz
Uwe
Bild
ZZTop
Aktiver Hörer
 
Beiträge: 51
Registriert: 15.03.2012, 14:27

Beitragvon uli.brueggemann » 24.12.2016, 13:54

ZZTop hat geschrieben:@Uli
was brauche ich dann um Acourate und Convolver neu zu installieren?

Vor der Neuinstallation die Lizenz vom AcourateConvolver im Lizenzfenster abmelden (=Parken auf dem Server). Dazu die ID notieren. Nach der Neusinstallation den AC installieren, registrieren und dann unter Eingabe der alten ID die Lizenz zurückholen.

Acourate: ich benötige dann die ID nach der Neuinstallation von Win

Grüsse
Uli
Bild
uli.brueggemann
Aktiver Hersteller
 
Beiträge: 3189
Registriert: 23.03.2009, 15:58
Wohnort: 33442

Beitragvon WongP » 24.12.2016, 14:15

Ich habe Win10 damals nach 40Stunden Einarbeitung und Optimierung letztendlich gelöscht und bin auf Win8 zurück.
Für mich heisst das: Windows 10 ist kein System für AudioPCs! Viele Dienste starten und Updates fahren hoch die man nicht steuern bzw. abschalten kann - nein auch nicht wenn man glaubt es einstellen zu können ;) Im Hintergrund laufen Prozesse immer wieder neu an und das System ändert sich eigentlich täglich - da hilft leider auch kein Fidelizer und keine Systemoptimieren.

Hier gibt es dennoch ein paar gute Hinweise zur Optimierung: https://support.focusrite.com/hc/en-gb/ ... Windows-10
Zusätzlich hilft auch z.B das tool: Antispy-Tool DoNotSpy10
Wer noch was Geld investieren möchte kann sich bei AUDIOPHILE OPTIMIZER 2.00 umschauen.

Frohes Fest
Michael
Bild
WongP
inaktiv
 
Beiträge: 131
Registriert: 02.03.2016, 00:03

Beitragvon Tinitus » 24.12.2016, 15:05

Da passt wieder eines meiner Lieblingszizate:

Wenn eine Sache genetisch versaut ist, helfen auch keine Schläge mehr.

G. Polt

Deshalb bevorzuge ich diese kleinen Biester die auf Linux Basis arbeiten.

Da gibt es bei Basteleien - jetzt denke ich an Loriot - keinen GAU.

Trotzdem Frohes Fest

Uwe
Bild
Tinitus
Aktiver Hörer
 
Beiträge: 704
Registriert: 10.11.2013, 21:48

Beitragvon Buellerich » 24.12.2016, 18:18

Moin Uwe

Du kannst zusätzlich das Power Management für USB verändern (siehe hier http://www.sweetwater.com/sweetcare/art ... windows-7/) klappt auch für win 10
Ich muss Michael Recht geben. Windows. 10 ist leider extrem dynamisch, jede Woche ein neues Update und nach jedem Neustart fragst Du Dich was jetzt wieder kaputt gegangen ist.
Das automatische Updaten kannst Du nur über das Ausschalten des entsprechenden Dienstes unterdrücken, natürlich mit allen Risiken.
Am besten ist dann wirklich der dezidierte Audio Rechner, der gar nicht mehr ans Netz geht.

Versuch beim Abspielen auch mal den Virenscanner abzuschalten.

Gruß

Sascha
Bild
Buellerich
Aktiver Hörer
 
Beiträge: 181
Registriert: 31.01.2015, 23:08

Beitragvon pschelbert » 24.12.2016, 18:51

Buellerich hat geschrieben:Moin Uwe

Windows. 10 ist leider extrem dynamisch, jede Woche ein neues Update
Das automatische Updaten kannst Du nur über das Ausschalten des entsprechenden Dienstes unterdrücken, natürlich mit allen Risiken.

Gruß
Sascha


Hallo

okay wusste nicht dass man Updates nicht mehr abschalten kann, ist offenbar neu seit Win10.

Frage, hat jemand probiert um z.B. via Firewall das Update einfachzu blockieren?
Wenn ja wie gehts?

Microsoft hat offenbar bis heute nicht verstanden wie Realtime geht, halt Real-Time Anfänger...seit 36 Jahren...
Linux ist klar sehr viel besser, ist ja auch auf solider Basis und von 1960 rum (Unix von Bell Labs), wohlüberlegt. Mir war der Aufwand zu gross.
Wobei, Win7 und Win8.1 laufen bei mir mit DAC und ADC auch sehr gut, eben mit ASIO Treiber. Ich habe gar keine Optimierung oder irgendwelche Prozesse abgeschaltet. Einfach Win7 und Win8 installiert und fertig.
Virenscanner/Firewall: hier habe ich tatsächlich nur den Windows-Firewall drin.

Mac ist theoretisch besser, basiert ja auf Berkley-Unix, läuft bei mir auch problemlos (MacPro15, OSX 10.8).

Peter
Bild
pschelbert
inaktiv
 
Beiträge: 1148
Registriert: 25.08.2015, 12:44

Beitragvon pschelbert » 24.12.2016, 18:57

Hallo

vom JRiver Forum:

stottern ist bekannt bei Win10, ein Grund war: Microsoft Antivirus Tool.

http://yabb.jriver.com/interact/index.p ... #msg689556

Ob es das bei Dir der Fall ist ist natürlich nicht gesagt.

Peter
Bild
pschelbert
inaktiv
 
Beiträge: 1148
Registriert: 25.08.2015, 12:44

Nächste

Zurück zu Computer-HiFi

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 2 Gäste