Tonverzögerung zum Bild - welche Lösung kennt Ihr ?

Ulis Mess- und Korrekturprogramm

Tonverzögerung zum Bild - welche Lösung kennt Ihr ?

Beitragvon Lauscher » 04.11.2017, 19:03

Hallo :D

Ich muss zum Anfang sagen das ich ein Acourate-Neuling bin der seine ersten Schritte geht und wahrscheinlich deshalb die Lösung zu meinem „Problem“ noch nicht kenne. Im Forum lese ich wohl das Dolby D auch mit Acourate + Weichenerstellung umgesetzt wird —aber nichts zum Zeitverzug oder der Vermeidung :D

Also lege ich einfach mal los: ich betreibe mein BD-Player extern gehe analog über meine externe Soundkarte in meinen PC und Falte den Ton mit Acourate. Das Bild geht direkt zum Fernseher. Dadurch ergibt sich eine Verzögerung im Ton - er hinkt hinterher.
Ich kann wohl das Bild um 200ms verzögern, das reicht aber leider nicht aus.

Nun wollte ich gerne wissen wie Ihr das „Problem“ löst ?

Einfallen würde mir im PC ein BD Laufwerk einbauen und das Bild per Software noch länger ausbremsen ? Aber bekomme ich damit auch so ein gutes Bild wie mit meinem BD Player hin ?
Oder ein anderen BD Player mit längerer Bildverzögerung ?

Ich würde mich über Eure Hinweise und Vorschläge freuen

Viele Grüße
Jens
Lauscher
Aktiver Hörer
 
Beiträge: 49
Registriert: 30.09.2017, 07:54

Beitragvon Buschel » 04.11.2017, 19:28

Hallo Jens,

per default erzeugt Acourate Filter mit Phasenkorrektur, die so ausgelegt sind, dass du 32.768 samples Verzögerung hast. Bei 44,1 kHz entspricht das etwa 0,74 Sekunden. Die einfachste Lösung für dein Problem ist, dass du auf die Phasenkorrektur verzichtest. Dazu erzeugst du in Acourate zuerst wie gewohnt deine Filter und ergänzt dazu im Anschluss das sogenannte minimum phase Filter (Acourate: "Room" > "Special: Convert Filters to Minphase"). Dabei geht nur die Phasenkorrektur verloren, der Frequenzgang bleibt erhalten, und die durch das Filter verursachte Verzögerung ist damit entfernt. Aber: Der Filterprozess selbst erzeugt auch noch eine Verzögerung. Die wiederum hängt von Einstellungen der Blockgröße der FFT zusammen. Je kleiner desto geringere Verzögerung, desto mehr Rechenlast.

Der Ton meiner Videoquellen wird auch mit minimum phase Filtern und mit geringer Latenz des Filterprozesses korrigiert. Ich muss das Bild nicht verzögern.

Grüße,
Andree
Bild
Buschel
Aktiver Hörer
 
Beiträge: 596
Registriert: 12.12.2013, 21:12
Wohnort: Raum Karlsruhe

Beitragvon Lauscher » 04.11.2017, 19:35

Hallo Andree :D

Danke für Deine schnelle Antwort. Das muss ich morgen gleich mal ausprobieren- mal sehen :D
Wenn ich das so hinbekomme wäre das Super.

Viele Grüße
Jens
Bild
Lauscher
Aktiver Hörer
 
Beiträge: 49
Registriert: 30.09.2017, 07:54

Beitragvon Lauscher » 05.11.2017, 21:32

Hallo Andree :D

Jup - die minphase Filter kann ich erstellen. Das hat prima funktioniert.

Zuerst hätte ich Schwierigkeiten die dbl Dateien in den Acourate Convolver zu bekommen :x bis ich begriffen habe das ich die Dateien natürlich auch in cpv umwandeln muss.

Allerdings kann ich die Zeitverzögerung an meinem BD Player nicht ausprobieren. Ich habe so viel an dem Setup des Players rumgefummelt das er nun den Ton nicht mehr ausgeben mag :|

Ich versuche es morgen nochmal.

Nochmal Danke für Deine Hilfe

Viele Grüße
Jens
Bild
Lauscher
Aktiver Hörer
 
Beiträge: 49
Registriert: 30.09.2017, 07:54

Beitragvon Lauscher » 09.11.2017, 23:53

Hallo :D

Ich habe nun meinen Player wieder im Griff- Ton ist wieder da :wink:

Ich begreife erst jetzt das bei den Playern nur der Ton verzögert werden kann und nicht das Bild.
In meiner Überschrift habe ich das auch so geschrieben aber anders gemeint. :oops:

Die Minphase könnte ich erzeugen aber eine merkliche Verkürzung der Zeit hat es noch nicht gebracht.
Da ich zur Zeit scheinbar mehrere Anläufe brauche gehe ich am Wochenende nochmal an das Thema.
Mal sehen was ich übersehen habe.
In der Wiki ist der Punkt leider noch ohne Erklärung. Obwohl einstellen kann ich ja nichts - das macht Acourate automatisch.

Kann eigentlich die Überschrift geändert werden ? „ Bildverzögerung zum Ton“

Viele Grüße
Jens
Bild
Lauscher
Aktiver Hörer
 
Beiträge: 49
Registriert: 30.09.2017, 07:54

Beitragvon chriss0212 » 10.11.2017, 08:44

Hallo Jens,

ich fürchte, da wirst Du nicht fündig werden. In der Regel ist es so, dass die Bildbearbeitung in den Gräten länger dauert weswegen normalerweise nur Tonverzögerung eingebaut ist. Bildverzögerung ist auf Grund der Datenmenge recht Speicherintensiv und teuer. Man muss bedenken, dass das Bild unkomprimiert abgespeichert wird... das sind dann ein paar MByte pro Bild... je nach Auflösung und Farbtiefe.

Da diese Funktion normalerweise nicht benötigt wird, sparen sich die Hersteller diese Kosten ;)

Viele Grüße

Christian
Bild
chriss0212
Aktiver Hörer
 
Beiträge: 2031
Registriert: 06.01.2015, 22:03
Wohnort: Wuppertal

Beitragvon Buschel » 10.11.2017, 09:25

Hallo Jens,

wenn minphase keine wesentliche Verkürzung der Zeit gebracht hat, ist etwas nicht richtig gemacht worden. Minphase verkürzt das delay bei 44,1 kHz um über 700 ms. Evtl. hast du die neuen Filter — die Dateinamen beginnen mit „mp“ — noch gar nicht benutzt?

Grüße,
Andree
Bild
Buschel
Aktiver Hörer
 
Beiträge: 596
Registriert: 12.12.2013, 21:12
Wohnort: Raum Karlsruhe

Beitragvon Lauscher » 10.11.2017, 15:22

Hallo Andree,

doch - die mp Datei habe ich in den AcourateConvolver eingebunden.
Zur Sicherheit habe ich es auch nur mit einem Kanal und nur mit 44,1 kHz versucht. Ohne Erfolg - auch die Anzeige auf der rechten Seite hat sich vom den Zahlen her nicht verändert.

Gestern hatte ich das nochmal versucht - war aber auch schon spät.

Ich versuche es heute oder morgen nochmal und schaue ob was ich bei den Dir erwähnten "Blockgröße der FFT" so einstellen kann. :? Gleichzeitig schaue ich auch immer wieder in der Wiki vorbei.

Ich werde auch nochmal mit dem LS Entfernungseinstellungen in dem AVR rumspielen.
Laut Handbuch kann ich bis zu 18 Meter Entfernung einstellen.

Da ja einige Acourateanwender das hinbekommen bin ich guter Dinge das ich mit etwas fummeln auch hinbekommen werde. Auf jeden Fall bekomme ich immer mehr Gefühl für das Programm und meine Geräte sowie für die externe Soundkarte.

@Christian: wie Du liest werde ich nicht aufgeben und bleibe ich am Ball :)


Viele Grüße an Euch
Jens
Bild
Lauscher
Aktiver Hörer
 
Beiträge: 49
Registriert: 30.09.2017, 07:54

Beitragvon uli.brueggemann » 10.11.2017, 15:50

Um beim AcourateConvolver die Latenz kleiner zu bekommen gibt es folgende Schritte:
a) minimalphasige Filter erstellen, davon cpv Filter erzeugen und diese verwenden
b) eine kleinere FFTsize auswählen z.B. anstelle 32768 (default) nun 8192 oder kleiner. Man wird feststellen, dass damit die CPU-Last ansteigt. > 50% macht keinen Sinn.
c) den Asio-Puffer kleiner machen. Zu klein macht aber auch keinen Sinn
d) falls die Latenz immer noch zu groß ist, dann in Acourate mit CutNWindow die Länge der minimalphasigen Korrekturfilter kürzen, anstelle 65536 (default) z.B. 16384. Das reduziert auch die CPU-Last, allerdings dann auch die Frequenzauflösung der Filter (Abtastrate/taps)

Bei Video wird man zum größten Teil vom Bild beschäftigt, die Reduzierung der Tonqualität macht sich damit weniger bemerkbar

Grüsse
Uli
Bild
uli.brueggemann
Aktiver Hersteller
 
Beiträge: 3403
Registriert: 23.03.2009, 16:58
Wohnort: 33442

Beitragvon Lauscher » 10.11.2017, 16:16

Hallo Herr Brüggemann,

Danke für Ihre umfangreichen Hinweise :D
Da habe ich ja eine Menge zum ausprobieren. Ich glaube ich muss nun schnell nach Hause :wink:

"Bei Video wird man zum größten Teil vom Bild beschäftigt, die Reduzierung der Tonqualität macht sich damit weniger bemerkbar" Da teile ich Ihre Meinung - wenn ich aber eine bessere Tonqualität bekommen kann - nehme ich diese sehr gerne mit. :D

Viele Grüße
Jens
Bild
Lauscher
Aktiver Hörer
 
Beiträge: 49
Registriert: 30.09.2017, 07:54

Beitragvon Auriga » 26.02.2018, 14:26

Hallo Allerseits,

ich habe das gleiche Problem wie Jens, jedoch in meinem Fall beim Audioschnitt. Wenn ich also bei meinem Wave-Editor (in meinem Fall Steinberg Wavelab) auf Play drücke, ist der Cursor auf der Wellenform immer diese ca. 700-800 ms vor dem zu hörenden Audio.
Ich setze hierbei einen VST-Convolver ein, da die ganzen Schnittprogramme auch als VST-Host arbeiten.

Klar, ohne Phasenkorrektur, also mit als Minphase konvertierten Filtern, habe ich das Problem nicht.
Allerdings würde ich gerne mit Phasenkorrektur hören.
Somit meine Frage: wie vermeide ich diesen Delay und kann trotzdem phasenkorrigierte Filter verwenden?

Herzliche Grüße aus Berlin

Andreas
Bild
Auriga
Aktiver Hörer
 
Beiträge: 25
Registriert: 09.01.2018, 20:58

Beitragvon wgh52 » 26.02.2018, 15:44

Andreas,

nachdem Du FIR Filter für die Phasenkorrektur bereits ab 20 Hz einsetzt, hast Du halt einen signifikanten Latenzeffekt durch die dafür nötige Rechenzeit und den darin einfließenden Signalzeitbereich. Das ist ja der Grund warum es z.B. bei Acourate die Alternative gibt für Film und Fernsehen nur mit IIR Filtern zu arbeiten, deren Latenz (Rechenzeit) sehr viel niedriger (praktisch nicht hörbar) ist. Von daher sehe ich erstmal keine Lösung für Deinen Bedarf.

Grüße,
Winfried

4428
Bild
wgh52
Aktiver Hörer
 
Beiträge: 4523
Registriert: 25.01.2008, 16:17
Wohnort: Schweitenkirchen

Beitragvon Buschel » 26.02.2018, 15:59

Hallo Andreas,

schau mal in diesen Thread: Klick mich.

Grüße,
Andree
Bild
Buschel
Aktiver Hörer
 
Beiträge: 596
Registriert: 12.12.2013, 21:12
Wohnort: Raum Karlsruhe

Beitragvon Auriga » 26.02.2018, 16:43

Lieber Winfried, lieber Andree,

wgh52 hat geschrieben:Andreas,
nachdem Du FIR Filter für die Phasenkorrektur bereits ab 20 Hz einsetzt, hast Du halt einen signifikanten Latenzeffekt durch die dafür nötige Rechenzeit und den darin einfließenden Signalzeitbereich. Das ist ja der Grund warum es z.B. bei Acourate die Alternative gibt für Film und Fernsehen nur mit IIR Filtern zu arbeiten, deren Latenz (Rechenzeit) sehr viel niedriger (praktisch nicht hörbar) ist. Von daher sehe ich erstmal keine Lösung für Deinen Bedarf.
4428


danke für Deine Überlegungen. Ich dachte die ganze Zeit auch, daß die Convolver unverschämt viel Rechenzeit bräuchten.
Allerdings habe ich heute morgen festgestellt, daß die Rechenzeit nicht mein Problem (i7-Prozessor 8) ) ist, sondern die Tatsache, daß Acourate als Voreinstellung bei der Filtergeneration den Peak erst nach der halben Filterlänge setzt, um vorher genügend Platz für die notwendige Phasenkorrektur zu haben - so wie im Threat von Andree hier beschrieben:
Buschel hat geschrieben:Klick mich
Andree
(Danke Dir Andree!)


Ich habe mir den Threat mal durchgelesen. Das ist ja die viel bessere Variante meiner bisherigen Lösung, bei der ich via CutNWindow einfach den Anfang, bei dem nichts ist, weggeschnitten habe, allerdings dann damit auch die Filterlänge halbiert habe.
Beide Lösungsansätze, entweder mit Rotation zu arbeiten, oder gleich im Makro die doppelte Filterlänge zu aktivieren, sind natürlich wesentlich besser. Ich denke mit 20ms Versatz werde ich einigermaßen hinkommen...
Ich probiere das nachher mal aus.

Euch nochmals besten Dank!

Herzliche Grüße,

Andreas
Bild
Auriga
Aktiver Hörer
 
Beiträge: 25
Registriert: 09.01.2018, 20:58

Beitragvon wgh52 » 26.02.2018, 16:51

Hallo Andreas,

wenn Du wirklich auf 20 ms Latenz kommst (die mir bei TV gerade noch nicht auffallen), wäre das bei halber Filterlänge eine gute Alternative. Mich würde dann aber auch die klangliche Seite interessieren: Welche Unterschiede zwischen beiden Varianten sind (mehr oder weniger deutlich) zu vernehmen?

Danke und Grüße,
Winfried

4430
Bild
wgh52
Aktiver Hörer
 
Beiträge: 4523
Registriert: 25.01.2008, 16:17
Wohnort: Schweitenkirchen

Nächste

Zurück zu Acourate

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste